1# Create the extraction directory (path can be customized as needed):
2sudo mkdir -p /tmp/es-center-server-upgrade-app
3
4# Extract the upgrade package into the target directory:
5sudo tar -xzvf es-center-server-upgrade-app-1.1.3-ge-1-202511111542.tar.gz -C /tmp/es-center-server-upgrade-app
6
7# Enter the upgrade-tool directory:
8cd /tmp/es-center-server-upgrade-app
9
10# Upgrade the service. Parameter descriptions:
11# `service-root-dir`: root directory of the installed service.
12sudo ./cli upgrade-server \
13--service-root-dir /opt/es-center-server-service1# Switch to the service installation directory
2cd /opt/es-center-server-service
3
4# Note: if `domain-name` was set to an internal or public IP during installation, the `update-server-ssl` command will report an error.
5sudo ./cli update-server-ssl